photo-2016-11-21-17-40-16_9642

VxRail ou l’art difficile de faire du plug’n play

Je vous ai conté à plusieurs reprises ici notre volonté d’investir en 2016 dans VxRail. L’objectif était à l’époque de pouvoir réellement confronter cette plateforme Hyper-Convergée à la situation d’une production réelle (en prévision d’un investissement éventuel beaucoup plus massif en 2018). Cela s’est traduit à l’époque par l’acquisition de deux clusters VxRail séparés : un cluster 3 Noeuds autonome pour héberger notre “pré-production” et un cluster 2×3 Noeuds en mode stretched pour absorber l’ensemble de nos “machines d’administration” (rendez-vous dans la section VxRail de ce blog pour plus d’info).

Même si l’architecture VxRail est, au départ, basée sur un regroupement de logiciels issus du même éditeur, VMware en l’occurence, placé sur une plateforme hardware industrielle, il ne faut pas sous-estimer la difficulté pour un constructeur, fut-il EMC, de produire et assurer la maintenance de tels environnements. On imagine souvent, à tord, qu’il s’agit juste de monter un bundle, y affecter une ligne de support dédié et “zou, on peut faire du business”. Non, définitivement, l’affaire n’est pas si simple.

Preuve en est, appuyée par notre propre expérience récente de client VxRail, que cet exercice reste un travail complexe et de longue haleine.

Lire la suite …

Photo-2015-10-05-14-04-40_7686

Attention à votre VPlex si vous mettez à jour vos VNX (ETA EMC)

Update 20/10/2015: attention, la première version de ce billet était incomplète. En plus du re-discover, vous devez faire tourner le script mentionné dans l’ETA pendant toute la phase de NDU de vos VNX. Désolé pour ces explications partielles. Nous allons dérouler précisément cette méthode très prochainement chez nous, je vous ferais un retour dès que possible.

Je viens de recevoir très récemment un ETA d’EMC estampillé numéro 000197315, à consulter ici. Il concerne les environnements VPlex disposant de back-end VNX. Il existe un risque de perte de connexion sur certaines LUNs provisionnées sur VNX en en cas d’update de flarecode. Toutes les générations et versions de VNX sont concernées car c’est un problème spécifique à VPlex. Les versions de VPlex impactées vont de la 4.0 à la 5.4. Ils ne précisent pas si la toute récente version 5.5 est elle aussi concernée, donc on imagine que non.

Lire la suite …